opebet网页版-bet亚洲官网手机版-登录

教育行业A股IPO第一股(股票代码 003032)

全国咨询/投诉热线:400-618-4000

传智教育|传智播客

一样的教育,不一样的品质

全国校区

 

Docker安装对开发平台的要求有哪些?

更新时间:2021年04月12日17时34分 来源:传智教育 浏览次数:

传智教育-一样的教育,不一样的品质


Docker支撑在多种平台上使用,包括Mac、Windows、Cloud以及Linux系统上等。由于Docker是基于Ubuntu发布的,所以官方更推荐在Ubuntu上使用Docker,开发者也可以根据自己的实际开发环境选择合适的开发平台。

Docker的安装并非想象中那么随意,在不同的平台上安装Docker必须满足不同的先决条件。由于本书选择在Ubuntu16.04版本上使用Docker,因此这里只针对Ubuntu系统上的Docker安装要求进行说明。

根据Docker官网上的安装说明,想要在Ubuntu上安装Docker需要满足两点要求,一是Ubuntu的版本支撑,二是Ubuntu的内核支撑,具体如下。

1. Ubuntu的版本支撑

● Ubuntu Trusty 14.04 (LTS)

● Ubuntu Xenial 16.04 (LTS)

● Ubuntu Zesty 17.04

● 其他更高的版本

2.Ubuntu的内核支撑

Docker需要在64位版本的Ubuntu上安装。此外,还需要保证Ubuntu的内核版本不低于3.10(可以通过uname -r命令查看),其中3.10版本和更新维护版也是可以使用的,在低于3.10版本的内核上运行Docker会丢失一部分功能。

小提示:

上述版本和内核要求是对Docker全面支撑的,也有一些开发者的版本或者系统无法满足条件,可以参考网上一些方法进行额外配置,达到满足Docker使用的需求,当然这种方法是不推荐的。

猜你喜欢:

Docker与虚拟机的区别有哪些?

Docker架构包括哪几部分?

Docker 安装教程|在线安装、离线安装和脚本文件安装

传智教育Java培训

opebet网页版|bet亚洲官网手机版

XML 地图 | Sitemap 地图